Autor Wątek: MSI MPG X570 Gaming Pro Carbon WIFI - RAID m.2 NVME  (Przeczytany 404 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

lukmouton

  • Sierżant
  • **
  • :
  • Wiadomości: 88
MSI MPG X570 Gaming Pro Carbon WIFI - RAID m.2 NVME
« dnia: 27 Styczeń 2020, 12:09:42 »

Witam.
pokusiłem się stworzenie Raid 0 wykorzystując  2 identyczne dyski ADATA SX8200 Pro na porcie M.2 Nvme.
Sprawa wygląda następująco.
Wydajność dysków jako AHCI oscyluje się około 2700/2000 (podczas testów, nawet przy kopiowaniu)
Stworzyłem Raid 0 połączyłem je w biosie zgodnie z instrukcją, oraz zainstalowałem Windows dodając najnowsze sterowniki do raid podczas instalacji.
Transfer liniowy wynosi około 4000-6000Mb/sek, buforowanie około 16000Mb/sek.
Ale jest jeden problem.
Raid bardzo często zamula podczas kopiowania transfer z 5000Mb/sek spada nawet do 150Mb/sek i wtedy jest 100% zajętości dysku.
Ja rozumiem, że prędkość raid spadnie ograniczając się do nośnika docelowego, ale w żadnym wypadku nie powinno mieć miejsca obciążenie raida do 100% ;)
Nawet Jak kopiuje na ten sam dysk Raid, to transfer z 2000Mb/s spada do 100Mb/sek ;)
Ale jako normalnie tryb AHCI podczas kopiowania zajętość dysku wynosiła maks 10% przy kopiowaniu na wolniejsze nośniki. Nie było wtedy "zamulania"
Co może być powodem, że nawet jak wykonuje test prędkości dysku na raid, to raz zamula odczyt, a raz zapis.
Temperatury dyskow m.2 oscylują się około 40-50 stopni.
Chipset X5700 około 40-60 stopni.
Zapisane
LG24GM77+LG24GM79
MSI MPG X570 GAMING PRO CARBON WIFI
AMD Ryzen 9 3900X
NZXT Kraken X62 V2
MSI GTX 1070 Ti Gaming 8GB
Patriot VIPER 2x8GB PC4-28800 3600Mhz
PSU Seasonic 660 Platinium.
SteelSeries Rival 600

keiytom

  • Generał
  • *****
  • :
  • Wiadomości: 822
Odp: MSI MPG X570 Gaming Pro Carbon WIFI - RAID m.2 NVME
« Odpowiedź #1 dnia: 27 Styczeń 2020, 18:47:45 »

Tu problemem są dyski, te które posiadasz pomimo tego, że są w miarę szybkie to:
ich wydajność spada w miarę zapełnienia,
posiadają o ile się nie mylę tylko 1GB pamięci podręcznej co jest największym problemem więc przy RAID 0 od razu się ona zapycha, dlatego jest obciążenie 100% i spada drastycznie ich wydajność.

Jeśli chciałbyś mieć wydajność RADI 0 na dyskach NvMe musiałbyś kupić jakieś dyski serwerowe choć nie wiem czy występują one na złączu M.2 raczej tylko na złączu PCIe np. Intel P4800X czy bardziej "konsumencki" https://www.morele.net/dysk-ssd-intel-optane-900p-series-aic-480gb-pcie-x4-nvme-ssdped1d480gasx-1638181/
Choć i tak mogą się zdarzyć sytuacje, że taka konfiguracja będzie wolniejsza niż pojedynczy dysk.

A jeśli chciałbyś sobie jedynie poprawić trochę wydajność, musiałbyś kupić dyski z większą ilością pamięci podręcznej np. Samsung 970 Pro najlepiej w jakiejś większej pojemności np. 1 TB który pamięci podręcznej posiada: 6GB dedykowanej i 36 GB dynamicznej, choć i tak zapis prawdopodobnie podczas testów wychodziłby gorzej niż przy pojedynczym dysku ponieważ w RAID bufor szybciej się zapełnia i są większe opóźnienia.
« Ostatnia zmiana: 27 Styczeń 2020, 19:49:20 wysłana przez keiytom »
Zapisane