Autor Wątek: Słaby transfer dysku M.2 na płycie Intel X99A Raider  (Przeczytany 970 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

michupl22

  • Szeregowiec
  • *
  • :
  • Wiadomości: 7
Słaby transfer dysku M.2 na płycie Intel X99A Raider
« dnia: 27 Lipiec 2017, 15:35:03 »

Witam,

Niedawno zakupiłem nowy zestaw komputerowy oparty na płycie głównej MSI X99A Raider. Dokupiłem do niego dysk na złącze M.2 - Samsung SSD PCIe 960 Pro. Celem było oczywiście szybki transfer danych. Ten model oferuje ponoć do 3 Gb/s odczytu. Komputera sam nie składałem. Był on składany w sklepie, a następnie w całości przysłany do mnie, ale przed zakupem całość została sprawdzona prze ze mnie. W dokumentacji MSI widnieje ten dysk jako wspierany. Wszystko działa, ale prędkość odczytu i zapisu tego dysku SSD wynosi maksymalnie 800 Mb/s. Nie wiem czy teraz wywaliłem niepotrzebnie pieniądze i czy podmieniać na jakiś inny dysk. W płycie pokazuje, że port SATA 5 i 6 jest zajęty przez M.2, ale przecież to jest dysk na PCIe.

Oprócz tego mam taką sytuację. Gdy włączę komputer to pochodzi 3 sekundy, wyłącza się i ponownie się włącza.
Zapisane

Nichrome

  • Administrator
  • Generał
  • *****
  • :
  • Wiadomości: 3922
  • Born to rule!
Odp: Słaby transfer dysku M.2 na płycie Intel X99A Raider
« Odpowiedź #1 dnia: 28 Lipiec 2017, 13:14:18 »

Witam

Porty SATA 5 i 6 są współdzielone jako SATA Express. I wg informacji na temat M.2 PCIe i Sata Express, możesz mieć podłączony dysk M.2 LUB 1 dysk SATA Express (lub 2 dyski SATA). Zerknij na zrzut w załączniku.

Co do drugiego problemu, mam wrażenie że po każdym wyłączeniu komputera całkowicie odłączasz zasilanie..?
Zapisane

Nie, nie pracuję dla MSI. Jakiekolwiek uwagi, pretensje, skargi, proszę kierować do MSI.
Nie udzielam pomocy przez Prywatne Wiadomości.

michupl22

  • Szeregowiec
  • *
  • :
  • Wiadomości: 7
Odp: Słaby transfer dysku M.2 na płycie Intel X99A Raider
« Odpowiedź #2 dnia: 01 Sierpień 2017, 16:21:05 »

Znaczy się mam jeden dysk M.2. Na SATA Express ani do portu SATA 5 i 6 nie mam nic podłączone. Mimo tego transfer nie przekracza 800 MB/s

Faktycznie odłączam całkowicie zasilanie. To znaczy mam podłączony komputer do listwy i gdy nie korzystam z komputera to ją po prostu wyłączam. Ale to znaczy, że komputer musi być ciągle na czuwaniu? Czy można to jakoś wyłączyć?
Zapisane

Nichrome

  • Administrator
  • Generał
  • *****
  • :
  • Wiadomości: 3922
  • Born to rule!
Odp: Słaby transfer dysku M.2 na płycie Intel X99A Raider
« Odpowiedź #3 dnia: 02 Sierpień 2017, 00:04:21 »

Zobacz na stronie Samsunga czy są jakieś sterowniki. Z tego co wiem, po instalacji takich (lub aktualizacji firmware dysku), transfer powinien skoczyć.

Co do zasilania, to jest to "naturalne" zachowanie płyt MSI po kompletnym odłączeniu od zasilania.
Zapisane

Nie, nie pracuję dla MSI. Jakiekolwiek uwagi, pretensje, skargi, proszę kierować do MSI.
Nie udzielam pomocy przez Prywatne Wiadomości.

michupl22

  • Szeregowiec
  • *
  • :
  • Wiadomości: 7
Odp: Słaby transfer dysku M.2 na płycie Intel X99A Raider
« Odpowiedź #4 dnia: 02 Sierpień 2017, 00:25:42 »

Sterowniki co prawda instalowałem najnowsze, ale firmware nie próbowałem. Zobaczę to w sobotę.

A jeśli chodzi o to zasilanie. Rozumiem, że mam to zignorować? Nie wpływa to znacząco na stan płyty czy podzespołów?
Zapisane

Nichrome

  • Administrator
  • Generał
  • *****
  • :
  • Wiadomości: 3922
  • Born to rule!
Odp: Słaby transfer dysku M.2 na płycie Intel X99A Raider
« Odpowiedź #5 dnia: 02 Sierpień 2017, 15:49:47 »

Zachowanie płyty nie ma wpływu na inne podzespoły. Osobiście nie wiem czemu jest takie zachowanie po odcięciu zasilania, ale może uda mi się dowiedzieć. Zauważyłem takie zachowanie już na Skylake (Z170). Na Haswell (Z87/Z97) tak nie było. Moja teoria jest taka, że płyta po takim odcięciu sprawdza czy nie ma gdzieś przeciążenia lub spięcia.
Zapisane

Nie, nie pracuję dla MSI. Jakiekolwiek uwagi, pretensje, skargi, proszę kierować do MSI.
Nie udzielam pomocy przez Prywatne Wiadomości.

michupl22

  • Szeregowiec
  • *
  • :
  • Wiadomości: 7
Odp: Słaby transfer dysku M.2 na płycie Intel X99A Raider
« Odpowiedź #6 dnia: 07 Sierpień 2017, 15:39:40 »

Sprawdziłem aktualizację oprogramowania dla dysku Samsung SSD 960 Pro za pomocą narzędzia Samsung Magician oraz na stronie internetowej. Z informacji jakie zostały pokazane wynika, że mój dysk posiada najnowszą wersję firmware. Mimo zrobienia testu narzędziem samsunga nadal maksymalny odczyt to 800 MB/s, a zapis 600 MB/s. Oprócz tego mimo zainstalowania wszystkich sterowników od MSI w menedżerze urządzeń pokazuje, że brakuje jeszcze dwóch:

Kontroler Uniwersalnej magistrali szeregowej (USB)
Nieznane urządzenie id: PCI\VEN_8086&DEV_8D31&SUBSYS_7A541462&REV_05

Nie mogę jednak dojść do tego co to za urządzenie. Głównie chodzi o to drugie. Może to powoduje problem.
Zapisane

Nichrome

  • Administrator
  • Generał
  • *****
  • :
  • Wiadomości: 3922
  • Born to rule!
Odp: Słaby transfer dysku M.2 na płycie Intel X99A Raider
« Odpowiedź #7 dnia: 08 Sierpień 2017, 02:20:19 »

Możliwe że to niepoprawnie wykryty dysk lub sterownik PCIe do dysku.
Masz możliwość sprawdzić ten dysk w innym PC?
Upewnij się że posiadasz najnowszą wersję BIOS, oraz że Intel ME w BIOS zgadza się z wersją zainstalowaną w Windowsie.
Zapisane

Nie, nie pracuję dla MSI. Jakiekolwiek uwagi, pretensje, skargi, proszę kierować do MSI.
Nie udzielam pomocy przez Prywatne Wiadomości.

michupl22

  • Szeregowiec
  • *
  • :
  • Wiadomości: 7
Odp: Słaby transfer dysku M.2 na płycie Intel X99A Raider
« Odpowiedź #8 dnia: 08 Sierpień 2017, 11:37:23 »

Niestety nie mam drugiego komputera z gniazdem M.2.

Brakujące sterowniki udało mi się doinstalować. Teraz w Menedżerze urządzeń nic nie brakuje.

Intel ME teraz się zgadza. BIOS z kolei mam w wersji E7A54IMS.320, a jego data wydania to 12/14/2016. Na stronie MSI jest z dnia 20/07/2016. Czyli wychodzi na to, że mam najnowszy. Komputer był składany w serwisie, więc możliwe, że od razu wszystko zaktualizowali, albo był już zaktualizowany.

W BIOSIE wymusiłem pracę M.2 na PCI, bo inaczej nie widzi dysku. W załączniku zrzut z Samsung Magician. Nadal transfer jest na poziomie 800 MB/s.
Zapisane

Nichrome

  • Administrator
  • Generał
  • *****
  • :
  • Wiadomości: 3922
  • Born to rule!
Odp: Słaby transfer dysku M.2 na płycie Intel X99A Raider
« Odpowiedź #9 dnia: 08 Sierpień 2017, 12:19:47 »

Ok, czyli nadal lipa.

Sprawdź temperatury dysku podczas testu. Te dziady grzeją się i to bardzo, i może u Ciebie w sekundę łapie 70C.
Zapisane

Nie, nie pracuję dla MSI. Jakiekolwiek uwagi, pretensje, skargi, proszę kierować do MSI.
Nie udzielam pomocy przez Prywatne Wiadomości.

michupl22

  • Szeregowiec
  • *
  • :
  • Wiadomości: 7
Odp: Słaby transfer dysku M.2 na płycie Intel X99A Raider
« Odpowiedź #10 dnia: 11 Sierpień 2017, 11:50:21 »

Sprawdziłem temperatury dysku. Podczas testu i podczas normalnego obciążenia podczas mojej pracy. Temperatura nie przekroczyła 40 stopni. Zarówno podczas stresu komputera za pomocą programu jak i podczas mojej pracy.

Podczas kiedy przeglądałem specyfikację komputera zauważyłem, że szyna, na której znajduje się dysk SSD jest zajęta przez kontroler ASMedia ASM1142 USB 3.1 xHCI Controller. Przez to Samsung pracuje w trybie x2. Czytałem w specyfikacji, że powinien w x4. Może to jest powodem? Da się to jakoś wyłączyć? I tak nie mam urządzenia, który pracuje na USB 3.1. Na 3.0 to jeszcze mam, ale nowszego już nie.
Zapisane

Nichrome

  • Administrator
  • Generał
  • *****
  • :
  • Wiadomości: 3922
  • Born to rule!
Odp: Słaby transfer dysku M.2 na płycie Intel X99A Raider
« Odpowiedź #11 dnia: 11 Sierpień 2017, 13:40:58 »

Nie jestem pewny..
Masz coś jeszcze podłączonego pod PCIe poza kartą graficzną?

40C podczas transferu wyjaśnia że dysk nie jest w 100% używany. Te dyski do 60-70C dochodzą.

Brakuje mi już, szczerze mówiąc, pomysłów.
Zapisane

Nie, nie pracuję dla MSI. Jakiekolwiek uwagi, pretensje, skargi, proszę kierować do MSI.
Nie udzielam pomocy przez Prywatne Wiadomości.

michupl22

  • Szeregowiec
  • *
  • :
  • Wiadomości: 7
Odp: Słaby transfer dysku M.2 na płycie Intel X99A Raider
« Odpowiedź #12 dnia: 11 Sierpień 2017, 14:45:04 »

W chwili obecnej mam tylko kartę graficzną. Na dysku mam wyłączony plik stronnicowania i buforowanie zapisu. Może dlatego przy teście nie obciąża dysku.

W BIOSIE wyłączyłem to USB 3.1, ale nadal pokazuje, że port jest zajęty. Tak myślę czy czasem gdzieś fizycznie nie trzeba tego odpiąć.

Zawsze mogę go spróbować oddać na gwarancji, ale nie wiem czy w tym przypadku zostanie ona uwzględniona, bo dysk właściwie działa. Bad sektorów nie ma, a mi się wydaje, że ta szyna PCIE x2 ona może coś psuć.
Zapisane